zoukankan      html  css  js  c++  java
  • PAT (Basic Level) Practice (中文)1015 德才论 (25 分)

    题目

    宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

    现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

    输入格式:
    输入第一行给出 3 个正整数,分别为:N(≤10​5​​ ),即考生总数;L(≥60),为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于 H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线 L 的考生也按总分排序,但排在第三类考生之后。

    随后 N 行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔。

    输出格式:
    输出第一行首先给出达到最低分数线的考生人数 M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

    输入样例:
    14 60 80
    10000001 64 90
    10000002 90 60
    10000011 85 80
    10000003 85 80
    10000004 80 85
    10000005 82 77
    10000006 83 76
    10000007 90 78
    10000008 75 79
    10000009 59 90
    10000010 88 45
    10000012 80 100
    10000013 90 99
    10000014 66 60
    输出样例:
    12
    10000013 90 99
    10000012 80 100
    10000003 85 80
    10000011 85 80
    10000004 80 85
    10000007 90 78
    10000006 83 76
    10000005 82 77
    10000002 90 60
    10000014 66 60
    10000008 75 79
    10000001 64 90

    C++实现

    #include <iostream>
    #include <algorithm>
    #include <vector>
    
    using namespace std;
    
    struct student_score {
        int student_ID,Moral_score,Talent_score;
    };
    
    int cmp(struct student_score a, struct student_score b) {
        if ((a.Moral_score + a.Talent_score) != (b.Moral_score + b.Talent_score))
            return (a.Moral_score + a.Talent_score) > (b.Moral_score + b.Talent_score);
        else if (a.Moral_score != b.Moral_score)
            return a.Moral_score > b.Moral_score;
        else
            return a.student_ID < b.student_ID;
    }
    
    int main() {
        int N, L, H;
        cin >> N >> L >> H;
        int total = N;
        struct student_score temp;
        vector<student_score> student[4];
        for (int i = 0; i < N; ++i) {
            cin >> temp.student_ID >> temp.Moral_score >> temp.Talent_score;
            if (temp.Moral_score < L || temp.Talent_score < L) total--;
            else if (temp.Moral_score >= H && temp.Talent_score >= H) student[0].push_back(temp);
            else if (temp.Moral_score >= H && temp.Talent_score < H) student[1].push_back(temp);
            else if (temp.Moral_score < H && temp.Talent_score < H && temp.Moral_score >= temp.Talent_score)
                student[2].push_back(temp);
            else student[3].push_back(temp);
        }
        cout << total << endl;
        for (int i = 0; i < 4; ++i) {
            sort(student[i].begin(), student[i].end(), cmp);
            for (int j = 0; j < student[i].size(); ++j) {
                cout << student[i][j].student_ID << ' ' << student[i][j].Moral_score << ' ' << student[i][j].Talent_score;
                cout << endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    Kubernetes实战模拟三(wordpress健康检查和服务质量QoS)
    Kubernetes实战模拟二(wordpress高可用)
    Kubernetes实战模拟一(wordpress基础版)
    Rook部署测试Ceph和wordpress实战应用
    kettle作业转换的执行
    BUU BURP COURSE 1
    BUU SQL COURSE 1
    BUU CODE REVIEW 1
    查看FGC
    Pod大量为Evicted被驱逐状态
  • 原文地址:https://www.cnblogs.com/AlexKing007/p/12338474.html
Copyright © 2011-2022 走看看