zoukankan      html  css  js  c++  java
  • 【菜鸟做水题】:杭电 find your present(用异或的解题思想)

    Problem Description
    In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
     
    Input
    The input file will consist of several cases. 
    Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
     
    Output
    For each case, output an integer in a line, which is the card number of your present.
     
    Sample Input
    5
    1 1 3 2 2
    3
    1 2 1
    0
     
    Sample Output
    3
    2
    Hint
    Hint
    use scanf to avoid Time Limit Exceeded
     
     
    #include<iostream>
    using namespace std;
    
    int main()
    {
        int num,n,result,i;
        while(scanf("%d",&n),n){
            result=0;            //如果重复出现,异或运算结果为0或者1,与0再做一次运算确保最终结果就为单独出现的元素
            for(i=0;i<n;++i){
                scanf("%d",&num);
                result^=num;// 异或运算,相同则为1,不同则为0
            }
            printf("%d\n",result);
        }
        return 0;
    }
    

      

    给梦想一点时间
  • 相关阅读:
    linux通过源码安装nodejs
    设置npm的镜像源
    ubuntu手动安装PhantomJS
    h2数据库的简单使用
    xampp启动失败 Apache shutdown unexpectedly
    phpqrcode实现二维码(含图片)
    php 使用 rabbitmq
    rabbitMQ linux安装
    rabbitmq的web管理界面无法使用guest用户登录
    linux安装使用xdebug
  • 原文地址:https://www.cnblogs.com/VortexPiggy/p/2669471.html
Copyright © 2011-2022 走看看