zoukankan      html  css  js  c++  java
  • poj 2431 Expedition

    Expedition
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12980   Accepted: 3705

    Description

    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

    * Line N+2: Two space-separated integers, L and P

    Output

    * Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS: 

    The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

    OUTPUT DETAILS: 

    Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
     
    题意:司机要从起点开到终点,中途会经过若干的加油站,每个加油站距离终点的距离以及每个加油站能够加多少油条件都会给出,求至少在多少个加油站加油能到达终点
    思路:问题可以考虑成:当车还有油时每经过一个加油站可以将加油站压入堆中(按每个加油站能加油的多少来决定压入堆后加油站的位置,车要加油时有多的加油站可以先出队列),当油耗尽还没到下一个加油站时再从堆中将之前经过的加油站一个一个pop出来,直到这些油足够能撑到下一个加油站为止。记录一共加几次油。
    AC代码:
    #define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<algorithm>
    #include<queue>
    using namespace std;
    const int N_MAX = 10000;
    struct fuel_stop {
        int ditance;
        int amount;
        bool operator <(const fuel_stop&b)const {
            return amount<b.amount || (amount == b.amount &&this->ditance>b.ditance);
        }
    };
    const bool cmp(const fuel_stop&a,const fuel_stop&b){
        return a.ditance < b.ditance;
    }
    priority_queue<fuel_stop>que;
    fuel_stop fuel[N_MAX+1];
    int main() {
        int N;
        while (cin >> N) {
            int dist[N_MAX];
            for (int i = 0;i <N;i++)
            scanf("%d%d",&dist[i],&fuel[i].amount);
            int L, P;
            cin >> L >> P;
            for (int i = 0;i <N;i++) 
                fuel[i].ditance = (L - dist[i]);
            sort(fuel,fuel+N,cmp);
            fuel[N].amount = 0;fuel[N].ditance = L;//把终点当做一个特殊的加油站点
            int pos = 0,tank=P,ans=0;//ans为加油次数,tank为油箱中油量,pos为当前位置
            for (int i = 0;i <=N;i++) {
                int d = fuel[i].ditance - pos;//d为当前距离下一个加油站的距离
                while (tank < d) {
                    if (que.empty()) {
                        cout<<-1<<endl;
                        return 0;
                    }
                    tank += que.top().amount;
                    ans++;
                    que.pop();
                }
                tank -= d;
                pos = fuel[i].ditance;
                que.push(fuel[i]);
            }
            cout << ans << endl;
        }
        return 0;
    }
     
     
     
  • 相关阅读:
    ios设备new Date('2019-07-26 11:00:00')报错
    vue图片压缩(不失真)
    ios微信端网页点击右上角复制链接或在浏览器打开,得不到当前页地址(动态路由)
    ios打开网页,输入框获取焦点键盘弹起,关闭键盘,界面下方空白不回弹
    vue-cli打包后vendor.js文件太大怎么办
    ios点击有300毫秒延迟,输入框必须重压或长按才能获取焦点唤起软键盘
    ios微信端上下滑动页面,若触摸的是input区域,页面内不滚动,整个页面被拖动了
    vue-cli打包优化之分析工具webpack-bundle-analyzer
    vue引入fastclick设置输入框type="number"报错Failed to execute 'setSelectionRange' on 'HTMLInputElement': The input element's type ('number') does not support selection.的解决办法
    js/vue图片压缩
  • 原文地址:https://www.cnblogs.com/ZefengYao/p/5837597.html
Copyright © 2011-2022 走看看