zoukankan      html  css  js  c++  java
  • POJ3349 Snowflake Snow Snowflakes (hash

    Snowflake Snow Snowflakes

    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 48624   Accepted: 12697

    Description

    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.



    代码如下:
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int maxn = 1e5+5;
    int n,tot,P=99991;
    int snow[maxn][6];
    int head[maxn];
    int nex[maxn];
    int H(int *a){
        int sum=0;
        int mul=1;
        for(int i=0;i<6;i++){
            sum=(sum+a[i])%P;
            mul=(long long)mul*a[i]%P;
        }
        return (sum+mul)%P;
    } 
    bool equal(int *a,int *b){
        for(int i=0;i<6;i++){
            for(int j=0;j<6;j++){
                bool eq=1;
                for(int k=0;k<6;k++){
                    if(a[(i+k)%6]!=b[(j+k)%6]) eq=0;
                }
                if(eq) return 1;
                eq=1;
                for(int k=0;k<6;k++){
                    if(a[(i+k)%6]!=b[(j-k+6)%6]) eq=0;
                }
                if(eq) return 1;
            }
        }
        return 0;
    }
    
    bool insert(int *a){
        int val=H(a);
        for(int i=head[val];i;i=nex[i]){
            if(equal(snow[i],a)) return 1;
        }
        ++tot;
        memcpy(snow[tot],a,6*sizeof(int));
        nex[tot]=head[val];
        head[val]=tot;
        return 0;
    }
    int main(){
        cin>>n;
        for(int i=1;i<=n;i++){
            int a[10];
            for(int j=0;j<6;j++) scanf("%d",&a[j]);
                if(insert(a)){
                    puts("Twin snowflakes found.");
                    return 0;
                }
        }
        puts("No two snowflakes are alike.");
    }
    View Code
    每一个不曾刷题的日子 都是对生命的辜负 从弱小到强大,需要一段时间的沉淀,就是现在了 ~buerdepepeqi
  • 相关阅读:
    不一样的抽象工厂模式(设计模式七)
    不一样的工厂模式(设计模式六)
    asp .net core 静态文件资源
    asp .net core 中间件
    平时写文档的文档要求
    mysql 悲观锁和乐观锁(二)
    Java实现 LeetCode 836 矩形重叠(暴力)
    Java实现 LeetCode 834 树中距离之和(DFS+分析)
    nmon数据采集参数
    Linux安装iostat命令
  • 原文地址:https://www.cnblogs.com/buerdepepeqi/p/9452951.html
Copyright © 2011-2022 走看看