zoukankan      html  css  js  c++  java
  • HDU1224-Free DIY Tour(SPFA+路径还原)

    Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour. 

    The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

    Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0. 

    Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it? 

    InputThe input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows. 
    Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map. 
    Then N integers follows, representing the interesting point list of the cities. 
    And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi. 
    OutputFor each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

    Output a blank line between two cases. 
    Sample Input

    2
    3
    0 70 90
    4
    1 2
    1 3
    2 4
    3 4
    3
    0 90 70
    4
    1 2
    1 3
    2 4
    3 4

    Sample Output

    CASE 1#
    points : 90
    circuit : 1->3->1
    
    CASE 2#
    points : 90
    circuit : 1->2->1

    题解:就是简单的最短路径+路径还原。。。PE了两发。。。注意格式。

    AC代码为:

    #include<bits/stdc++.h>
    using namespace std;
    int T,n,m,u,v,cas,a[1010],temp[1010];
    int vis[110],dis[110],fa[110],Map[110][110];


    void spfa()
    {
        queue<int> q;
        q.push(1);vis[1]=1;
        while(!q.empty())
        {
            int u=q.front(); q.pop();
            vis[u]=0;
            for(int i=2;i<=n+1;i++)
            {
                if(Map[u][i] && dis[i]<dis[u]+a[i])
                {
                    dis[i]=dis[u]+a[i];
                    fa[i]=u;
                    if(!vis[i]) q.push(i),vis[i]=1;
                }   
            }   
        } 
    }


    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);cas=0;
        cin>>T;
        while(T--)
        {
            memset(vis,0,sizeof vis);
            memset(dis,0,sizeof dis);
            memset(Map,0,sizeof Map);
            memset(a,0,sizeof a);
            cin>>n;
            for(int i=1;i<=n;i++) cin>>a[i];
            cin>>m;
            for(int i=1;i<=m;i++)
            {
                cin>>u>>v;
                Map[u][v]=1;
            }
            spfa(); 
            cout<<"CASE "<<++cas<<"#"<<endl;
            int flag=fa[n+1],cnt=0;
            temp[0]=1;
            while(flag)
            {
                temp[++cnt]=flag;
                flag=fa[flag];
            }
            cout<<"points : "<<dis[n+1]<<endl;
            cout<<"circuit : ";
            for(int i=cnt;i>=0;i--) i==0? cout<<temp[i]<<endl : cout<<temp[i]<<"->"; 
            if(T) cout<<endl;   
        }
        return 0;
    }

  • 相关阅读:
    微信小程序-上传多张图片加进度条(支持预览、删除)
    php中120个内置函数
    angular6 NgModule中定义模块module
    Aliasing input/output properties
    angular6 Can't bind to 'zzst' since it isn't a known property of
    [转]DOM 中 Property 和 Attribute 的区别
    Angular6
    [转]VirtualBox 修改UUID实现虚拟硬盘复制
    pthread_create如何传递两个参数以上的参数
    linux 线程操作问题undefined reference to 'pthread_create'的解决办法(cmake)
  • 原文地址:https://www.cnblogs.com/csushl/p/9386762.html
Copyright © 2011-2022 走看看