zoukankan      html  css  js  c++  java
  • CCNA笔记(一)

    R1#enable
    R1#configure terminal
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 12.1.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#hostname CCNA-name
    CCNA-name(config)#no ip domain-lookup
    CCNA-name#show version
    CCNA-name#show ip interface brief
    CCNA-name#show ip route
    CCNA-name(config)#line vty 0 4
    CCNA-name(config-line)#logging synchronous

    show version 查看当前设备完整信息
    show ip interface brief 查看当前接口信息
    show interfaces fastEthernet 0/0
    show ip route
    enable secert ...密码
    service password-encryption 密码设置成非明文
    no service password-encryption 相反

    R1:
    enbale
    interface fast 0/0
    ip address 12.1.1.1 255.255.255.0
    no showdown
    R2:
    enbale
    interface fast 0/0
    ip address 12.1.1.2 255.255.255.0
    no showdown
    R2:
    line vty 0 4
    password cisco
    login
    enable password miller
    R1:
    telnet 12.1.1.2
    cisco
    enbale
    miller

    挂起三次会话
    R1show session
    R2 show user

    R1:
    R1#enable
    R1#configure terminal
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 12.1.1.1 255.255.255.0
    R1(config-if)#no shutdown

    R2:
    R2#enable
    R2#configure terminal
    R2(config)#interface fastEthernet 0/0
    R2(config-if)#ip address 12.1.1.2 255.255.255.0
    R2(config-if)#no shutdown

    R2(config)#line vty 0 4
    R2(config-line)#password cisco
    R2(config-line)#login
    R2(config)#enable password miller

    R1#:telnet 12.1.1.2
    cisco
    enable
    miller
    R2#挂起会话3次
    R1show sess
    R2show user

    静态路由:
    R1(config)#interface loopback 0
    R1(config-if)#ip address 1.1.1.1 255.255.255.0
    R1(config)#ip route 2.2.2.0 255.255.255.0 12.1.1.2

    R2(config)#interface loopback 0
    R2(config-if)#ip address 2.2.2.2 255.255.255.0
    R2(config)#ip route 1.1.1.0 255.255.255.0 12.1.1.1

    R1:ping 2.2.2.2 source 1.1.1.1


    R2(config)#hostname R2
    R2(config)#no ip domain-lookup
    R2(config-line)#exec-timeout 0 0
    R2(config-line)#no logging synchronous

    dhcp实验
    R2(config)#ip dhcp pool ccna
    R2(dhcp-config)#network 12.1.1.0 255.255.255.0
    R2(dhcp-config)#default-router 12.1.1.253

    静态路由实验
    ip route 网络号 子网掩码 下一跳/本地出口 管距

    路由协议
    routing : RIP OSPF EIGRP BGP
    routed: ip

    route rip
    version 2
    network network-name

    静态路由:
    ip route 目的网络(网络号) 目的网络(子网掩码) 下一跳地址/本地出接口号

    RIP:
    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#no auto-summary
    R1(config-router)#network 1.0.0.0
    R1(config-router)#network 12.0.0.0

    OFPS
    ABR区域边界路由器,至少有一个接口连接骨干区域,其他接口连接非骨干区域。可以进行三类las的通道,这样的路由器我们称为ABR
    ASBR自制系统边界路由器。至少要有一个接口属于OSPF,可以将OSPF域外的路由重发向ospf。

    OSPF算法
    候选对象数据库 到根的代价 树数据库
    (R1,R1,0)
    Hello报文
    Router ID 区分路由器id
    Hello and dead intervals
    Neighbors 活跃的邻居
    Area ID 接口划分

    DR指定路由器,他是一个伪节点

    失效状态
    尝试状态
    初始状态
    双向通信状态 two-way(邻居关系的建立)
    信息交换状态
    信息加载状态
    完全邻接状态

    OFPS实验
    R1(config-if)#ip ospf network point-to-point 修改接口网络类型为点到点(loopback变成24位)
    R1(config-if)#ip ospf priority 100 需改接口优先级
    R1(config)#router ospf 100
    R1(config-router)#network 12.1.1.1 0.0.0.0 area 0
    R1#show ip ospf neighbor 查看邻居
    R1#show ip ospf database 查看链路状态数据库
    R1#show ip ospf interface 查看所有启用OSPF的接

    (config-router)maximum-paths<value>
    (config-if)ip ospf cost <value>

    散列式算法特点
    MD5(128bit)-SHA1(160).2(256)
    1,不登场输入---等长输出
    2.计算过程不可逆
    3.雪崩效应
    4,冲突避免

    R2(config-router)#area 0 authentication 区域下启用明文验证
    R2(config-router)#area 0 authentication message-digest 区域下启用MD5验证

    R2(config-if)#ip ospf authentication 接口下启用明文验证
    R2(config-if)#ip ospf authentication message-digest 接口下启用MD5验证

    R2(config-if)#ip ospf authentication-key cisco 接口下启用密钥“cisco”

    EIGRP
    MFT组播流计时器,组播切换单播。
    RTO重传超时计时器。SRTT平均往返时间。

    带宽k1,延迟k3,Reliability k2,Load k4,5 (10^7/ban +delay/10)x256=metric EIGRP=metric/256
    variance multiplier(倍数)
    FD可行距离

    R1(config)#key chain ccna 创建密钥链
    R1(config-keychain)#key 1 创建key
    R1(config-keychain-key)#key-string cisco 配置key1的密钥为“cisco”
    第四步配置时间省略......
    R1(config-if)#ip authentication mode eigrp 100 md5 接口下启用MD5身份验证
    R1(config-if)#ip authentication key-chain eigrp 100 ccna 使用“ccna”这个key-chain来对eigrp做认证

  • 相关阅读:
    Uipath-Close Application和Close Window区别
    我与某猪同学斗智斗勇的那些事
    可视报表(Project)
    自定义函数(Power Query 之 M 语言)
    报表(Project)
    拆分…Split…(Power Query 之 M 语言)
    参加Mos考试
    主要视图展示(Project)
    听听文档(视频)-Power Pivot
    突出显示(Project)
  • 原文地址:https://www.cnblogs.com/jingtyu/p/7541728.html
Copyright © 2011-2022 走看看