zoukankan      html  css  js  c++  java
  • VRRP协议

    1、启动设备,设置PC1PC2IP地址、子网掩码和网关

    2、配置SW1信息:

    <Huawei>undo terminal monitor               关闭弹窗

    <Huawei>system-view                             进入系统试图

    [Huawei]user-interface console 0              

    [Huawei-ui-console0]idle-timeout 0 0          永不超时

    [Huawei-ui-console0]sysname RSW1                改名

    [RSW1]vlan batch 10 20 100                       划分vlan10 20 100

    [RSW1]int g0/0/1                         (配置G0/0/1trunk口,允许10 20流量通过)   

    [RSW1-GigabitEthernet0/0/1]port link-type trunk

    [RSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

    [RSW1-GigabitEthernet0/0/1]int g0/0/2  (配置G0/0/2access口,允许10 20流量通过)

    [RSW1-GigabitEthernet0/0/2]port link-type access

    [RSW1-GigabitEthernet0/0/2]port default vlan 100

    [RSW1-GigabitEthernet0/0/2]quit

    [RSW1]int vlanif 10

    [RSW1-Vlanif10]ip add 192.168.10.10 24         

    [RSW1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1    配置虚拟IP地址

    [RSW1-Vlanif10]vrrp vrid 1 priority 120                 配置优先级120

    [RSW1-Vlanif10]vrrp vrid 1 track interface g0/0/1   配置监听口G0/0/1,当这个地方DOWN,优先级减10

    [RSW1-Vlanif10]vrrp vrid 1 track interface g0/0/2    配置监听口G0/0/2,当这个地方DOWN,优先级减10

    [RSW1-Vlanif10]int vlanif 20

    [RSW1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1      

    [RSW1-Vlanif20]ip add 192.168.20.10 24                   配置虚拟IP地址

    [RSW1-Vlanif20]vrrp vrid 2 priority 115                  配置优先级115       

    [RSW1-Vlanif10]int vlanif 100

    [RSW1-Vlanif100]ip add 11.0.0.2 30                       配置互联口IP地址

    [RSW1-Vlanif100]undo shutdown

    [RSW1-Vlanif100]quit

    [RSW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1            配置默认路由

    3、配置SW2信息:

    <Huawei>undo terminal monitor

    <Huawei>system-view

    [Huawei]user-interface console 0

    [Huawei-ui-console0]idle-timeout 0 0

    [Huawei-ui-console0]sysname RSW2

    [RSW2]vlan batch 10 20 100

    [RSW2]int g0/0/1

    [RSW2-GigabitEthernet0/0/1]port link-type trunk

    [RSW2-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

    [RSW2-GigabitEthernet0/0/1]int g0/0/2

    [RSW2-GigabitEthernet0/0/2]port link-type access

    [RSW2-GigabitEthernet0/0/2]port default vlan 100

    [RSW2-GigabitEthernet0/0/2]quit

    [RSW2]int vlanif 10

    [RSW2-Vlanif10]ip add 192.168.10.20 24

    [RSW2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1

    [RSW2-Vlanif10]vrrp vrid 1 priority 115

    [RSW2-Vlanif10]int vlanif 20

    [RSW2-Vlanif20]ip add 192.168.20.20 24

    [RSW2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1

    [RSW2-Vlanif20]vrrp vrid 2 priority 120

    [RSW2-Vlanif20]vrrp vrid 2 track interface g0/0/1

    [RSW2-Vlanif20]vrrp vrid 2 track interface g0/0/2

    [RSW2-Vlanif20]int vlanif 100

    [RSW2-Vlanif100]ip add 12.0.0.2 30

    [RSW2-Vlanif100]undo shutdown

    [RSW2-Vlanif100]quit

    [RSW2]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

    4、配置SW3信息:

    <Huawei>undo terminal monitor

    <Huawei>system-view

    [Huawei]user-interface console 0

    [Huawei-ui-console0]idle-timeout 0 0

    [Huawei-ui-console0]sysname SW3

    [SW3]vlan batch 10 20 100

    [SW3]int g0/0/1

    [SW3-GigabitEthernet0/0/1]port link-type trunk

    [SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

    [SW3-GigabitEthernet0/0/1]int g0/0/2

    [SW3-GigabitEthernet0/0/2]port link-type trunk

    [SW3-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20

    [SW3-GigabitEthernet0/0/2]int e0/0/1

    [SW3-Ethernet0/0/1]port link-type access

    [SW3-Ethernet0/0/1]port default vlan 10

    [SW3-GigabitEthernet0/0/2]int e0/0/2

    [SW3-Ethernet0/0/2]port link-type access

    [SW3-Ethernet0/0/2]port default vlan 20

    [SW3-Ethernet0/0/2]undo shutdown

    Info: Interface Ethernet0/0/2 is not shutdown.

    [SW3-Ethernet0/0/2]quit

    5、配置R1信息:

    <Huawei>undo terminal monitor

    <Huawei>system-view

    [Huawei]user-interface console 0

    [Huawei-ui-console0]idle-timeout 0 0

    [Huawei-ui-console0]sysname R1

    [R1]int g0/0/0

    [R1-GigabitEthernet0/0/0]ip add 11.0.0.1 30

    [R1-GigabitEthernet0/0/0]undo shutdown

    [R1-GigabitEthernet0/0/0]int g0/0/1

    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 30

    [R1-GigabitEthernet0/0/1]undo shutdown

    [R1-GigabitEthernet0/0/1]int loop 0

    [R1-LoopBack0]ip add 1.1.1.1 32

    [R1-LoopBack0]quit

    [R1]ip route-static 192.168.10.0 24 11.0.0.2                   配置静态路由

    [R1]ip route-static 192.168.20.0 24 11.0.0.2 preference 70  配置静态路由

    [R1]ip route-static 192.168.10.0 24 12.0.0.2 preference 70   配置静态路由

    [R1]ip route-static 192.168.20.0 24 12.0.0.2                     配置静态路由

    6、向上配置默认路由,向下配置静态路由,指的是在SW1SW2上设置默认路由、R1上设置静态路由。组播地址:224.0.0.18

  • 相关阅读:
    Microsoft .NET Framework 2.0实现发送邮件(Email)总结
    Microsoft .NET Framework 2.0对文件传输协议(FTP)操作(上传,下载,新建,删除,FTP间传送文件等)实现汇总
    抽象类
    WingIDE 单步调试 Uliweb Python 代码
    Android 4.0 SDK的离线方式安装
    .NET 3.5 中WCF客户端代理性能改进以及最佳实践
    在linux上部署Redmine
    认识jQuery mobile 框架,资源,书籍
    如何使用搜索技巧来成为一名高效的程序员
    Management Console 工具管理类软件通用开发框架(开放源码)
  • 原文地址:https://www.cnblogs.com/xuhao0705/p/13405907.html
Copyright © 2011-2022 走看看