zoukankan      html  css  js  c++  java
  • Legal or Not ,图的拓扑

    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

    输入:

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

    输出:

    For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

    样例输入:
    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0
    
    样例输出:
    YES
    NO
    

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<vector>
    #include<stack> 
    using namespace std;
    
    vector<int> edge[101];
    stack<int> s;
    int main(){
        int m,n;
        int in[101];
        while (cin>>n>>m && !(n==0&&m==0)){
            
            for (int i=0;i<n;i++){
                in[i]=0;
                edge[i].clear();
            }
            int x,y;
            while(m--){
                cin>>x>>y;
                in[y]++;
                edge[x].push_back(y);
            }
            
            while(!s.empty()) s.pop();
            
            for (int i=0;i<n;i++){
                if (in[i] == 0)
            s.push(i);
            }
            
            int ans=0;
            while (!s.empty()){
                int temp=s.top();
                s.pop();
                ans++;
                for (int i=0;i<edge[temp].size();i++){
                    in[edge[temp][i]]--;
                    if (in[edge[temp][i]] == 0)
                    s.push(edge[temp][i]);
                }
            }
            if (ans==n)
            cout<<"YES"<<endl;
            else
            cout<<"NO"<<endl;
            
        }
        
        return 0;
    }

    一个大错误:一直wa,跟答案比对了很久,难道只因为我用了栈他用了队列?

    不相信玄学,继续找

    发现是判断输入的m和n是不是0那里出错了,之前的好几道题自己都这么写,并没有错,但是这道就错了

    不应该是cin>>n>>m && n!=0&&m!=0而是cin>>n>>m && !(n==0&&m==0)

    ╮(╯▽╰)╭

  • 相关阅读:
    童年
    转:如何破解超星打印页数限制
    2016.7.14.2014noip模拟赛D1(网上貌似搜不到
    商店购物
    几道有趣的题
    2016.7.11.第27套测试题(noip2013提D1)
    2016.7.12.第28套测试题(2013noip题D2)
    跨域访问http接口的使用
    心得之——程序的修改和拓展
    不使用<script>导入js文件
  • 原文地址:https://www.cnblogs.com/yexiaoqi/p/7236449.html
Copyright © 2011-2022 走看看