zoukankan      html  css  js  c++  java
  • poj 3253 Fence Repair

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 27043   Accepted: 8792

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


    题意:分割一块长度为a的木板,须要花费a。问将一木板分割成下面板的长度的最小花费。

    解题思路:先找出两块最小的木板。将两块木板合并。新的木板放入木板堆了。然后再找出两块最小的木板,继续合并。放入,然后再。

    。。直到仅仅剩一块木板。

    #include <iostream>
    #include <queue>
    using namespace std;
    typedef long long ll;
    #define MAX_N 20000+5
    int N,L[MAX_N];
    void solve(){
    	ll ans=0;
    	priority_queue< int, vector<int> , greater<int> > que;
    	for (int i=0;i<N;i++)
    		que.push(L[i]);
    	while (que.size()>1){
    		int l1,l2;
    		l1=que.top();
    		que.pop();
    		l2=que.top();
    		que.pop();
    		ans+=l1+l2;
    		que.push(l1+l2);
    	}
    	cout<<ans<<endl;
    }
    int main(){
    	while (cin>>N){
    		for (int i=0;i<N;i++)
    			cin>>L[i];
    		solve();
    	}
    	return 0;	
    }


  • 相关阅读:
    qt解决中文乱码
    二维数组及指针分析
    pyhon Django框架
    java回调(钩子函数)
    java.util.concurrent java并发工具包
    CountDownLatch 计数器
    报表 图形接口查询 (年月周日)
    pg 日期函数
    linux 执行脚本报错 No such file or directory
    python 处理数据常用操作
  • 原文地址:https://www.cnblogs.com/yjbjingcha/p/6955556.html
Copyright © 2011-2022 走看看